Corrupted Block Database. How to solve it?

  • Hi

    I've been using the QT wallet for a few weeks since the swap. Today, I had to do a system restore on my computer because of some settings I've messed up. I have backup in order, passphrase and the private key. So, I'm not worried but still a bit concerned with this behavior. When I started the QTUM wallet after the system restore I got the error:

    "Corrupted block database detected. Do you want to rebuilt the block database now?"
    And then: "Error opening block database"

    • repeatedly tried to answer yes. The chain are re-downloaded again. Does not help.
    • upgraded the QT wallet to 0.14.7. Does not help.
    • ran the Qtum-Qt --salvagewallet command. That DID recover my roughly 20% tokens that was missing in the old wallet, but it did not remove the startup error.
    • deleted the whole installation and reinstalled. Does not help.
    • tried the QT win64 and the win64 setup version of the wallet. Does not help.
    • tried to run the wallet with no previous wallet backup. Does not help.

    Same error message of corrupt and bad blocks/chain no matter what.

    Anyone have an idea of what's wrong?

  • When you deleted the entire installation, did you delete the QTUM folder in "Roaming"?

Log in to reply